رفتن به مطلب
  • 0

سئوال در مورد اجرای برنامه روی اندروید 5.1


reza47

سوال

سلام دوستان

بنده با api چهارده برناممو کامپایل میکردم و خط زیر رو در مانی فست قرار نمیدادم:

SetApplicationAttribute(android:theme, "@android:style/Theme.Holo")

 

بعدش دیدم در کافه بازار کسانیکه گوشیشون اندروید 5.1 بود عنوان کردن که روی گوشی ما اجرا نمیشه

این در حالیه که اندروید گوشی خودم 5.0 هست و تست کردم اجرا میشه

حالا سئوالم اینجاست که برای اینکه برنامم از اندروید 2.2 تا اندروید 5.1 اجرا بشه با حداقل چه api کامپایل کنم و قرار دادن خط تم holo در مانی فست چه تاثیری داره آیا لازمه؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

12 پاسخ به این سوال تاکنون داده شده است

ارسال های توصیه شده

نکته ی اول اینکه شما همیشه باید با اخرین نسخه ی sdk دارید باید کامپایل کنید اون هیچ ربطی به اینکه روی چه نسخه ی اندوریدی بیاد نداره برای اینکه روی تمامی نسخه ها بیاد minsdk رو روی 10 بگذارید که این رو هم من توصیه نمیکنم چون خیلی از کتابخونه ها رو نمی تونید روی 2 ران بگیرید و همین دچار مشکل میکنه کار شما رو بهترین حالت اینه که min رو روی 15 بگذارید به سفارش گوگل . داخل برنامه هم حتما تم متریال هم بگذارید تا روی گوشی ها بالای 5 تم برنامه متریال بشه و مشکلی هم از این بابت ایجاد نشه 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

داخل برنامه هم حتما تم متریال هم بگذارید تا روی گوشی ها بالای 5 تم برنامه متریال بشه و مشکلی هم از این بابت ایجاد نشه 

منظور از تم متریال چیه؟ یعنی در هر گوشی برنامه یه شکلی در میاد؟ این کد تم holo مال چیه اصن؟

شما میفرمایید با sdk پانزده کامپایل کنم و در مانی فست ادیتور هم مقدار minsdk رو برابر 15 قرار بدم؟

منظور از platform همون sdk است؟ من پلتفرم 14و15و17 رو دارم ولی توی configuration patch الان مسیر 15 رو بهش دادم

لطفا به عکس پیوست نگاه کنید و اگر جایی اشکالی میبینید بگید

post-5652-0-58663100-1460140715_thumb.png

لینک ارسال
به اشتراک گذاری در سایت های دیگر

منظور از تم متریال چیه؟ یعنی در هر گوشی برنامه یه شکلی در میاد؟ این کد تم holo مال چیه اصن؟

شما میفرمایید با sdk پانزده کامپایل کنم و در مانی فست ادیتور هم مقدار minsdk رو برابر 15 قرار بدم؟

نه داداش من گفتم با اخرین sdk که داری کامپایل کن تا 23 بیشتر منتشر نشده  حالا شما اخرین sdk دارای باهاش کامپایل کن.   min  رو هم اگر هم روی 15 بگذاری دقت کن روی اندورید 4 به بالا میاد. که گفتم بهتره روی همین 15 بگذاری چون درصد اندورید 2 زیر 3درصد هست و ارزش نداره کیفیت رو فدای کمیت کنی  تم هم میتونی تم متریال بگذاری کنار تم هلو خود برنامه تشخیص میده روی اندورید 5 به بالا تم برنامه متریال میشه میتونی هم تم هلو برداری کلا متریال بگذار که زیر اندورید 5 باز تشخیص میده تم هلو میشه 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

شما نسخه ی sdk کامل  رو تهیه کنید و برای کامپایل از پلتفورم 23 استفاده کنید بقیه موارد رو هم بهتون توضیح دادم به اندازه ی کافی داداش

لینک ارسال
به اشتراک گذاری در سایت های دیگر

با پلتفرم 23 روی اندروید 4 به پایین اجرا میشه؟

گفتم که پلتفرم ربطی به اجرا شدن روی نسخه های اندورید رو نداره اون مربوط به min هست . 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

منکه گیج شدم. یک نفر بیاد درست درمون توضیح بده لطفا

 

سلام

ببینید دوستم شما با نسخه 23 بیا برنامه رو کامپایل کن ، اما minsdk رو بزار 15

دوستمون هم واضح گفتن که.

شما برای اینکه بخوایید متریال رو پیاده کنید نیاز دارید تا از نسخه 23 استفاده کنید ( البته 20 به بالا هم میشه ) برای اینکه به راحتی از جدیدترین امکانات و یا قابلیت هاش استفاده کنید از 23 استفاده کنید تا بتونید از دیزاین ساپورت هم استفاده کنید

لینک ارسال
به اشتراک گذاری در سایت های دیگر

سلام

ببینید دوستم شما با نسخه 23 بیا برنامه رو کامپایل کن ، اما minsdk رو بزار 15

دوستمون هم واضح گفتن که.

شما برای اینکه بخوایید متریال رو پیاده کنید نیاز دارید تا از نسخه 23 استفاده کنید ( البته 20 به بالا هم میشه ) برای اینکه به راحتی از جدیدترین امکانات و یا قابلیت هاش استفاده کنید از 23 استفاده کنید تا بتونید از دیزاین ساپورت هم استفاده کنید

فرق minsdk با targetsdk در مانی فست چیه؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

فرق minsdk با targetsdk در مانی فست چیه؟

 

minsdk  »  حداقل نسخه ای که برنامه شما به خوبی اجرا بشه و کار کنه ( ببنید توی هر نسخه ای امکانی جدید اضافه و یا حذف میشه ) شما فرضا در نظر بگیر از سنسور ها استفاده می کنید و ویک برنامه دارید که کل کارش با سنسور هستش اما ( برای مثال ) آندروید 2.x.x  این قابلیت رو نداره و باید شما اینجا  مینیموم sdk  رو روی اندروید نسخه 3 بزارید

 

targetsdk  هم همون نسخع ای هستش که دارید باهاش کامپایل می کنید و میخوایید از قابلیت های اون نسخه استفاده کنید ( اگه اشتباه نکنم )

شما تارگت بزارید 23 و مینیموم رو سعی کنید روی 14 بزارید.حالا بسته به خودتون دوست دارید رو نسخه پایین تر هم بزارید.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

مهمان
این موضوع برای عدم ارسال قفل گردیده است.
  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...