رفتن به مطلب
  • 0

سوال در رابطه با بیسیک فور اندروید


1messi

سوال

آیا نرم افزار که توسط بیسیک فور اندروید ساخته شده باشند ، از تمام سیستم عامل های اندروید و تمامی شرکت ها ( سامسونگ - هاوایی و ...)  پشتیبانی می کنند؟ 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

11 پاسخ به این سوال تاکنون داده شده است

ارسال های توصیه شده

دوستان یکی نیس api ها ور توضیح بده ؟

من دار یه کتاب میسازم باید از چه api استفاده کنم؟

API یا (ای پی آی) ها به جور بسته هستن برای نسخه های مختلف اندروید که در اونا تمامی ابزار هایی که در دسترس هستن در اون نسخه API وجود دارن .

ببینید خیلی ساده تر بگم به جور اندروید هستن .

مثلا اگر در اندروید 5 ابزار جدیدی اضافه شده باشه ما باید API 21 رو استفاده کنیم . اگر از API 20 - 19 استفاده کنید دیگه نمی تونید از اون ابزار استفاده کنید .

این API ها دارای توده بزرگی از کلاس ها هستن که برای اندروید نویسی لازمه . در هر ورژنی که بالاتر می ره تعداد کلاس ها افزایش می یابه و دسترسی شما به نقاط بیش تر گوشی می رسه .

اگر توضیحات کافی نیست بفرمایید بیش تر توضیح بدم ...

 

خوب حالا شما برای ساخت کتاب بهتره از API 14 استفاده کنید .

لازم به ذکره که شما اگر API 14 رو انتخاب کنید می تونید روی ورژن های اندروید بالاتر از این هم استفاده کنید؛ ولی اگر روی ورژن های پایین تر امتحان کننید احتمالا به مشکل بر بخورید (البته اگر از ابزار خاصی استفاده کرده باشید)

من برای ساخت کتاب API 14 رو توصیه می کنم .

لینک ارسال
به اشتراک گذاری در سایت های دیگر

سلام

از تمام شرکت ها که بله

اما برای ساخت برنامه متناسب با ورژن های مختلف، نه فقط در B4A بلکه حتی در جاوا هم، باید نسخه api متناسب با اون ورژن از اندروید رو برای sdk دانلود کنید

موفق باشید :gol:

لینک ارسال
به اشتراک گذاری در سایت های دیگر

سلام

از تمام شرکت ها که بله

اما برای ساخت برنامه متناسب با ورژن های مختلف، نه فقط در B4A بلکه حتی در جاوا هم، باید نسخه api متناسب با اون ورژن از اندروید رو برای sdk دانلود کنید

موفق باشید :gol:

میشه یکمی ساده تر توضیح بدید ؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

والا چی بگم؟:)

همه ی شرکتا پشتیبانی میشن

فقط برای نسخه های مختلف اندروید، باید یه چیزایی به sdk اضافه کنی :)

لینک ارسال
به اشتراک گذاری در سایت های دیگر

والا چی بگم؟ :)

همه ی شرکتا پشتیبانی میشن

فقط برای نسخه های مختلف اندروید، باید یه چیزایی به sdk اضافه کنی :)

چه چیزای باید اضافه کرد؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

api عزیزم

مثلا برای فعال شدن اندروید 5، api 21 رو باید نصب کنی

و من، برنامه هایی رو که با api21 مینویسم، روی اندروید 4.2 راحت نصب میشن...

منم تو بحث api ها یکم گیج میشم

دوستان خیلی کامل تر برات توضیح میدن

لینک ارسال
به اشتراک گذاری در سایت های دیگر

برادرم @mohamadali98

اگر پاسخ پستی رو نمیدونید، لازم نیست زیرش پاسخ بدید عزیزم

این پست ها اسپمن و اگر تکرار بشه، اخطار میگیرید

موفق باشید :gol:

لینک ارسال
به اشتراک گذاری در سایت های دیگر

این کلاس ها چی هستند ؟

شما با این کلاس ها کار نمی کنید و نمی تونید اون ها رو تعریف کنید .

منظورتون از چی هستن یعنی چی ؟

خود اون برنامه ای که باهاش برنامه نویسی میکنید این ها رو می شناسه و بدون این API ها نمی تونید از برنامه کامپایل بگیرید ..

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

مهمان
این موضوع برای عدم ارسال قفل گردیده است.
  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...