رفتن به مطلب
  • 0

مشکل با حذف اطلاعات یک فیلد در دیتابیس


alinoori

سوال

سلام 

من یه دیتا بیس دارم که یه تیبل لینک و توی این تیبل یه فیلد دارم.

دیتا بیسم اپ کردم.

خب کاربر میتونه لینک سایت رو توی دیتا بیس قرار بده و اضافه کنه به اطلاعات

منم این اطلاعات که حاویه لینکه با مولتی پنل به نمایش میزارم.طبق این کدا:

Sub Globals
	
	Private ScrollView1 As ScrollView
	Private Button1m As Button
	Private Panel1m As Panel
	
	Dim stop As Int=3%y
	Private Label1 As Label
	
	Private Button1 As Button
	Private Buttondel As Button
End Sub



Sub Activity_Create(FirstTime As Boolean)
	Activity.LoadLayout("up1")

	c1= S1.ExecQuery ("SELECT * FROM link")
	For i = 0 To c1.RowCount-1
	c1.Position = i
Dim p As Panel
p.Initialize("p")

ScrollView1.Panel.AddView(p,0,stop,100%x,100%y)
stop=stop+35%y
p.LoadLayout("multipanel")

Label1.Text=c1.GetString("lnk")

Button1.Tag=c1.GetString("lnk")
Buttondel.Tag=c1.GetString("lnk")
ScrollView1.Panel.Height=stop

	
	Next
	
	
End Sub


Sub Button1_Click
Dim iz As Button
iz=Sender
	Dim i As Intent
i.Initialize(i.ACTION_VIEW, iz.Tag)
StartActivity(i)
	
End Sub


Sub Buttondel_Click
	Dim del As Button

del=Sender



مشکل اینجاس که باید حذف کنه ولی نمیکنه. ؟؟؟؟؟؟؟
	S1.ExecNonQuery("DELETE FROM link where lnk="&del.Tag)	



End Sub








توی مولتی پنل یه باتن گداشتم برای حذف لینک(Buttondel)

ولی نمیدونم چرا لینک رو حذف نمیکنه؟

link.zip

لینک ارسال
به اشتراک گذاری در سایت های دیگر

4 پاسخ به این سوال تاکنون داده شده است

ارسال های توصیه شده

سلام

بالاخره بعد سه روز فهمیدم مشکلو

مجید ارتا یه دنیا ممنون به خاطر این پستت:

http://answercenter.ir/topic/127-%D8%A2%D9%85%D9%88%D8%B2%D8%B4-%D8%A7%D8%B6%D8%A7%D9%81%D9%87-%D8%AD%D8%B0%D9%81-%D9%88-%D9%88%DB%8C%D8%B1%D8%A7%DB%8C%D8%B4-%D8%A7%D8%B7%D9%84%D8%A7%D8%B9%D8%A7%D8%AA-%D8%AF%D8%B1-%D8%AF%DB%8C%D8%AA%D8%A7%D8%A8%DB%8C%D8%B3/

S1.ExecNonQuery("DELETE FROM link where lnk="&del.Tag)	

بالایی غلطه و کد پایینی برای حذف درسته

  S1.ExecNonQuery("DELETE FROM link where lnk ='"&del.Tag&"' ")
لینک ارسال
به اشتراک گذاری در سایت های دیگر

یه فیلد id  هم گذاشتم درست نشد 

کسی کمک نمیکنه؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

یک بار تگ رو  خروچی بگیر  ببین چیزی که میخواهی توش هست یا نه .. بنظرم مشکل از تگ باشه ظاهرا اشکال دیگه ای نداره ..

لینک ارسال
به اشتراک گذاری در سایت های دیگر

تگ مشکلی نداره

چون تو لیبل میارم نشونش میده.

اینم از ارور

photo_2015_08_27_06_34_55.jpg

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

مهمان
این موضوع برای عدم ارسال قفل گردیده است.
  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...