رفتن به مطلب
  • 0

اجرا برنامه روی اندروید های مختلف


mehdi.m

سوال

سلام.میشه یکی به من بگه چی چیزی باعث میشه برنامه روی اندروید های مختلف اجرا بشه؟؟؟؟؟؟

platform تاثیر داره؟؟؟مثلا 10 باشه یا 21 که آخریشه.........

 

و یه سوال دیگه 

توی مانیفست نوشته 

<uses-sdk android:minSdkVersion="4" android:targetSdkVersion="14"/>

مال چیه؟؟؟؟؟

 

متشکرم

لینک ارسال
به اشتراک گذاری در سایت های دیگر

4 پاسخ به این سوال تاکنون داده شده است

ارسال های توصیه شده

ببینید شما پلتفورمی که استفاده میکنید برای برنامه نویسی هیچ تاثیری رو اجرا نداره ، فقط شما از طریق همون یه قطعه کد توی منیفست هست میتونین تعیین کنید که حداقل اندروید مورد نیاز برای اجرا چند باید باشه ،

uses-sdk android:minSdkVersion="4"

توی این قسمت میگیم اگه ورژن sdk گوشی زیر 4 بود برنامه اجرا نشه ، 

android:targetSdkVersion="14"

اینجا هم تارگت رو مشخص میکنیم که بهتره همیشه آخرین ورژن رو انتخاب کنیم برای مثال اگه 20 بزاریم و برای برنامه تمی مشخص نکنیم ، اون برنامه روی اندروید 5 به صورت تم متریال اجرا میشه ، ولی اگه تارگت رو 14 بزاریم روی اندروید 5 تم هولو اجرا میشه ، بهتره اینو همیشه روی بیشترین مقدار بزارین  (این مقدار تاثیری روی ورژن های پایین تر نداره و اگه زیاد باشه باز هم برنامه روی ورژن های پایین اجرا میشه)

سلام...

آخرین مقدارش چنده!!!؟؟؟؟؟؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

سلام...

آخرین مقدارش چنده!!!؟؟؟؟؟؟

اخرین ورژن api 23 می باشد که برای اندروید 6 میباشد که ملقب به مارشملو

لینک ارسال
به اشتراک گذاری در سایت های دیگر

مشکل منم همینه، تازه یه سوال دیگه هم دارم، آیا نیاز هست که بین sdk مینیموم تا sdk ماکزیموم که اینجا ۱۰ و ۲۱ نوشتید بقیه sdkها هم باشن یا فقط همین ماکزیموم کافیه؟ عایا؟

Sent from my HTC Desire 500 dual sim using Tapatalk

لینک ارسال
به اشتراک گذاری در سایت های دیگر

ببینید شما پلتفورمی که استفاده میکنید برای برنامه نویسی هیچ تاثیری رو اجرا نداره ، فقط شما از طریق همون یه قطعه کد توی منیفست هست میتونین تعیین کنید که حداقل اندروید مورد نیاز برای اجرا چند باید باشه ،

uses-sdk android:minSdkVersion="4"

توی این قسمت میگیم اگه ورژن sdk گوشی زیر 4 بود برنامه اجرا نشه ، 

android:targetSdkVersion="14"

اینجا هم تارگت رو مشخص میکنیم که بهتره همیشه آخرین ورژن رو انتخاب کنیم برای مثال اگه 20 بزاریم و برای برنامه تمی مشخص نکنیم ، اون برنامه روی اندروید 5 به صورت تم متریال اجرا میشه ، ولی اگه تارگت رو 14 بزاریم روی اندروید 5 تم هولو اجرا میشه ، بهتره اینو همیشه روی بیشترین مقدار بزارین  (این مقدار تاثیری روی ورژن های پایین تر نداره و اگه زیاد باشه باز هم برنامه روی ورژن های پایین اجرا میشه)

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

مهمان
این موضوع برای عدم ارسال قفل گردیده است.
  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...