رفتن به مطلب
  • 0

یک خط از manifest


babi.jonz

سوال

سلام دوستان لطفا این خط رو توضیح بدید که چی هستش

<uses-sdk android:minSdkVersion="16" android:targetSdkVersion="14"/>

و بگید که از کدوم آی پی آی استفاده کنم که همه گوشی هارو پشتیبانی کنه.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

6 پاسخ به این سوال تاکنون داده شده است

ارسال های توصیه شده

متاسفانه بعضی از دوستان آدرس غلط میدن که سبب گم  راهی میشه minSdkVersion حداقل API هست

 

خوب ما هم همینو گفتیم اینجا کسی به غیر این نگفته :sorry:

 

 

 

و اینکه یکی از دوستان گفت تم هلو داخل برنامه بگذار تا برای همه جواب بده این کاملا غلط هست

 

لطفا درست بخونید من نگفتم که تم هلو قرار بدید من گفتم تم هلورو هلو لایگت قرار بدید تا برا اندروید های پایین سازگار تر باشه!

لینک ارسال
به اشتراک گذاری در سایت های دیگر

خوب ما هم همینو گفتیم اینجا کسی به غیر این نگفته :sorry:

 

 

 

لطفا درست بخونید من نگفتم که تم هلو قرار بدید من گفتم تم هلورو هلو لایگت قرار بدید تا برا اندروید های پایین سازگار تر باشه!

شما گفتید حداقل api روی 6 بگذارید که این غلط هست فقط سبب میشه خیلی  از کتابخونه ها جواب ندن  شما رو 10 بگذارید روی تمام نسخه ها جواب میده اومدید گفتید از largheap استفاده کنید  داخل تکه کدی دادید که این هم گفتم غلط هست دلیلش بالا گفتم اومدید گفتید بیشتری api که داری بگذار روی آخرین که این هم غلط هست  تارگت بحث تمرکز هست نه بیشترین api 

بیشترین api ماکسیمم هست که می تونید به مانیفست اضافه کنید تارگت بیشتر از 22  بگذارید به بعضی دسترسی ها داخل برنامه گیر میده مثل دسترسی تماس روی اندوید 6  گفتید تم برنامه هلو لایت باشه که روی همه جواب بده که این هم غلط هست شما تم متریال هم بگذارید روی همه جواب میده و روی اندورید 5 به بالا هم متریال میشه تم . 

این اشتباهات شما بود

لینک ارسال
به اشتراک گذاری در سایت های دیگر

سلام دوستان لطفا این خط رو توضیح بدید که چی هستش

<uses-sdk android:minSdkVersion="16" android:targetSdkVersion="14"/>

و بگید که از کدوم آی پی آی استفاده کنم که همه گوشی هارو پشتیبانی کنه.

سلام

با این خط شما میای و حداقل نسخه ای از اندروید رو که میخوای برنامت با اون سازگاری داشته باشه رو یه عدد قرار میدی = min sdk و عبارت target sdk هم به معنای نسخه ی اندرویدی است که به عنوان هدف انتخاب میشه  ، طبیعتا هر نسخه ای از اندروید رو در تارگت قرار بدین سازگاری بیشتری برنامتون با اون نسخه داره

لینک ارسال
به اشتراک گذاری در سایت های دیگر

از این کد استفاده کن برا مانیفستت که با بیشتر گوشی ها و گوشی هایی با API پایین سازگار باشی

'This code will be applied to the manifest file during compilation.
'You do not need to modify it in most cases.
'See this link for for more information: http://www.b4x.com/forum/showthread.php?p=78136
AddManifestText(
<uses-sdk android:minSdkVersion="6" android:targetSdkVersion="23"/>
<supports-screens android:largeScreens="true" 
    android:normalScreens="true" 
    android:smallScreens="true" 
    android:anyDensity="true"/>)
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")
SetApplicationAttribute(android:theme, "@android:style/Theme.Holo.Light")
SetApplicationAttribute(android:largeHeap,"true")
SetManifestAttribute(android:installLocation, "auto")
'End of default text.

کمترینش رو 6 بذار و بیشترینشم آخرین API که تو پلتفورمت داری و انتخابش کردی بذار

همچنین تم هم باید Holo.Light باشه که اندروید های پایین بتونن برنامه رو اجرا کنن

 

بهتره android:installLocation رو auto باشه و تو اکتیویتی ماین هم #CanInstallToExternalStorage: رو True  بذارید

لینک ارسال
به اشتراک گذاری در سایت های دیگر

@@babi.jonz,

طبق آمار بیشتر گوشی های اندرویدی روی api 19 و 21 کار میکنند که 19 بیشتر جواب گو هست

لینک ارسال
به اشتراک گذاری در سایت های دیگر

متاسفانه بعضی از دوستان آدرس غلط میدن که سبب گم  راهی میشه minSdkVersion   حداقل API هست که برنامه ی شما روی آن جواب میده من خودم 15 میگذارم چون اندورید 2.3 و 4.0  روی هم 4 درصد بازار رو دارا می باشن اگر شما بخواین روی اندورید پایین جواب بده مجبورین بعضی از کتابخونه ها رو نادیده بگیرید . ولی اگر میخواین روی 2.3 هم جواب بده که من توصیه نمیکنم کیفیت رو فدای کمیت کنید ولی اگر خواستید روی 10 بگذارید .

android:targetSdkVersion    تمرکز برنامه شما رو نشون میده که به این معنی که هدف اصلی برنامه ی شما برای چه API هست با توجه به اینکه بیشترین آمار بر اساس آخرین آمار گوگل اندورید 5 هست بهتره روی 21  یا 22 گذاشته بشه  و اینکه یکی از دوستان گفت تم هلو داخل برنامه بگذار تا برای همه جواب بده این کاملا غلط هست همونجور که می دونید در بیسیک 5.8 تم هلو از مانیفست حذف شده دلیلش هم اینه بیشترین سهم بازار رو اندورید 5 داره نباید شما از تم هلو استفاده کنید شما تم متریال رو داخل برنامه تون بگذارید روی تمامی API ها جواب میده فقط زیر اندورید 5 اپتون متریال نیست .

همچنین شما از Largheap  نباید بدون دلیل داخل مانیفست اضافه کنید چون سبب میشه نرم افزار های clear  اپتون شناسایی کنن و سرویس هاش رو غیرفعال میکنن  و یک خواهش هم از دوستان دارم کسی سوال میکنه آدرس غلط ندید که گمراه بشه 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

مهمان
این موضوع برای عدم ارسال قفل گردیده است.
  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...