رفتن به مطلب
برای استفاده از انجمن و عضـویت کلیک کنید.

AnswerCenter

مرکز پاسخگویی به سوالات برنامه نویسی

  • مرجع پاسخگویی
  • تولید آموزش
  • سفارش پروژه

درخواست سفارش پروژه

اطلاعیه

کاربر گرامی

به انجمن برنامه نویسی AnswerCenter.ir خوش آمدید

 برای استفاده از تمامی امکانات سایت لطفا در انجمن عضو شوید


  • 0
koke_sa

تداخل پوشه با sliding menu warper

سوال

koke_sa    40

کاربر عادی

سلام مشکل دارم فکرم نکنم درست بشه . من از sliding menu warper استفاده میکنم و نمیخوام از چیز دیگه ای استفاده کنم وقتی حتی فقط تیک کتابخونه پوشه رو میزنم این خطا میاد

B4A Version: 8.00
Parsing code.    (0.11s)
Compiling code.    (0.07s)
Compiling layouts code.    (0.00s)
Organizing libraries.    (2.51s)
Generating R file.    (0.40s)
Compiling generated Java code.    (5.20s)
Convert byte code - optimized dex.    Error
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/annotation/AnimRes;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/annotation/AnimatorRes;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/annotation/AnyRes;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/annotation/ArrayRes;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/annotation/AttrRes;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/annotation/BinderThread;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/annotation/BoolRes;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/annotation/CallSuper;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/annotation/CheckResult;
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.RuntimeException: Translation has been interrupted
	at com.android.dx.command.dexer.Main.processAllFiles(Main.java:689)
	at com.android.dx.command.dexer.Main.runMonoDex(Main.java:313)
	at com.android.dx.command.dexer.Main.run(Main.java:279)
	at com.android.dx.command.dexer.Main.main(Main.java:247)
	at com.android.dx.command.Main.main(Main.java:106)
Caused by: java.lang.InterruptedException: Too many errors
	at com.android.dx.command.dexer.Main.processAllFiles(Main.java:681)
	... 4 more

وقتی یکی از این دو کتابخونه رو تیکش بر میدارم دیگه مشکلی نیست و ران میشه . مشخص که این دو با هم تداخل دارن . من حتی روی یک پروژه خام ساده که فقط توش تیک این دو رو زدم هم تست کردم و مشکل دارن . اگر کسی این مشکل داشته لطف کنه بگه تا هم من هم بقیه استفاده کنن . ممنون . نسخه پوشه 1.04             نسخه سلایدر منو هم 1

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

8 پاسخ به این سوال تا کنون داده شده است

پست های پیشنهاد شده

  • 0
koke_sa    40

کاربر عادی

در 4 دقیقه قبل، M-CAP7AIN گفته است :

پوشه از روش استانداردی برای b4a استفاده نکرده .

برای کتابخونه هایی که همراه پوشه استفاده میشه باید به این صورت تغییر کنه


<dependsOn>***support-v4***</dependsOn>

به


<dependsOn>support-v4</dependsOn>

تغییر کنه.

 

pushe1.4.1-additional-libs.rar

این دوتا رو جایگزین و تست کنید.(ولی بازم با برخی از کتابخونه ها تداخل پیدا میکنه )

 

واقعا ممنون هم متوجه شدم از راهنمایی شما هم مشکل حل شد . خیلییییی ممنون

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
M-CAP7AIN    507

پاسخگو و راهنما

 

اگه نتونستید ، کتابخونه های استفاده شده رو پیوست کنید تا ویرایش کنم.

  • ذوق زده 1

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
koke_sa    40

کاربر عادی

در 13 دقیقه قبل، M-CAP7AIN گفته است :

 

اگه نتونستید ، کتابخونه های استفاده شده رو پیوست کنید تا ویرایش کنم.

سلام ممنون میشم کمک کنید . کتابخونه ها پیوست شد

پیوست

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
M-CAP7AIN    507

پاسخگو و راهنما

فقط کتابخونه SlidingMenuWrapper با مسیر کتابخونه های اصلی جایگزین بشه،

اگه با کتابخونه های دیگه ام تداخل داشت فایل xml  رو باز کنید هر قسمت که support-v4 مانند زیر داشت

<dependsOn>***support-v4***</dependsOn>

به

<dependsOn>support-v4-24.1.1.aar</dependsOn>

تغییر بدید.

New Folder.rar

  • پسندیدن 1

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
koke_sa    40

کاربر عادی

در در 1397/07/18, 09:10:44، M-CAP7AIN گفته است :

فقط کتابخونه SlidingMenuWrapper با مسیر کتابخونه های اصلی جایگزین بشه،

اگه با کتابخونه های دیگه ام تداخل داشت فایل xml  رو باز کنید هر قسمت که support-v4 مانند زیر داشت


<dependsOn>***support-v4***</dependsOn>

به


<dependsOn>support-v4-24.1.1.aar</dependsOn>

تغییر بدید.

New Folder.rar

سلام بازم نشد باور کنید دیگه خسته شدم . حتی کتابخونه sliding menu warper   رو کلا از پروژم برداشتم به جاش از ah navigation draver استفاده کردم  باز هم همون خطا اومده  .  هرچی هست کتابخوه پوشه به یه چیزی مشکل داره اخه تیک هر کدوم از این دورو برمیدارم بی مشکل ران میشه توی انجمن خیلی گشتم گفتنه بودن باید کلاس های هم نام رو از یکی از کتابخونه ها حذف کرد اما کلاس همنامی ندیدم . الان دیگه واقها نمیدونم مشکل از همنام بودن یا مشکل از چیز دیشگت مثلا sdk من فایل مانیفست پروژم رو قرار میدم همراه با این دو کتابخونه خواهش میکنم چک کنید خبر بدید واقعا شرمندم

 

این یک پروژه خام ساده که فقط تیک دوتا کتابخونه ها خورده شده

 این مانیفست

AddManifestText(
<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="21"/>
<supports-screens android:largeScreens="true" 
    android:normalScreens="true" 
    android:smallScreens="true" 
    android:anyDensity="true"/>)
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")

اینم خطا

B4A Version: 8.00
Parsing code.    (0.00s)
Compiling code.    (0.19s)
Compiling layouts code.    (0.00s)
Organizing libraries.    (0.00s)
Generating R file.    (0.80s)
Compiling generated Java code.    (1.89s)
Convert byte code - optimized dex.    Error
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/BuildConfig;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoIcsImpl;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoJellyBeanMr2;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoStubImpl;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoVersionImpl;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompatIcs;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompatJellyBeanMr2;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/animation/AnimatorCompatHelper;
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.RuntimeException: Translation has been interrupted
	at com.android.dx.command.dexer.Main.processAllFiles(Main.java:689)
	at com.android.dx.command.dexer.Main.runMonoDex(Main.java:313)
	at com.android.dx.command.dexer.Main.run(Main.java:279)
	at com.android.dx.command.dexer.Main.main(Main.java:247)
	at com.android.dx.command.Main.main(Main.java:106)
Caused by: java.lang.InterruptedException: Too many errors
	at com.android.dx.command.dexer.Main.processAllFiles(Main.java:681)
	... 4 more

 اینم دوتا کتابخونه ها

لینک این دو با هم

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
M-CAP7AIN    507

پاسخگو و راهنما

در 10 ساعت قبل، koke_sa گفته است :

سلام بازم نشد باور کنید دیگه خسته شدم . حتی کتابخونه sliding menu warper   رو کلا از پروژم برداشتم به جاش از ah navigation draver استفاده کردم  باز هم همون خطا اومده  .  هرچی هست کتابخوه پوشه به یه چیزی مشکل داره اخه تیک هر کدوم از این دورو برمیدارم بی مشکل ران میشه توی انجمن خیلی گشتم گفتنه بودن باید کلاس های هم نام رو از یکی از کتابخونه ها حذف کرد اما کلاس همنامی ندیدم . الان دیگه واقها نمیدونم مشکل از همنام بودن یا مشکل از چیز دیشگت مثلا sdk من فایل مانیفست پروژم رو قرار میدم همراه با این دو کتابخونه خواهش میکنم چک کنید خبر بدید واقعا شرمندم

 

این یک پروژه خام ساده که فقط تیک دوتا کتابخونه ها خورده شده

 این مانیفست


AddManifestText(
<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="21"/>
<supports-screens android:largeScreens="true" 
    android:normalScreens="true" 
    android:smallScreens="true" 
    android:anyDensity="true"/>)
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")

اینم خطا


B4A Version: 8.00
Parsing code.    (0.00s)
Compiling code.    (0.19s)
Compiling layouts code.    (0.00s)
Organizing libraries.    (0.00s)
Generating R file.    (0.80s)
Compiling generated Java code.    (1.89s)
Convert byte code - optimized dex.    Error
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/BuildConfig;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoIcsImpl;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoJellyBeanMr2;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoStubImpl;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoVersionImpl;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompatIcs;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompatJellyBeanMr2;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Landroid/support/v4/animation/AnimatorCompatHelper;
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.RuntimeException: Translation has been interrupted
	at com.android.dx.command.dexer.Main.processAllFiles(Main.java:689)
	at com.android.dx.command.dexer.Main.runMonoDex(Main.java:313)
	at com.android.dx.command.dexer.Main.run(Main.java:279)
	at com.android.dx.command.dexer.Main.main(Main.java:247)
	at com.android.dx.command.Main.main(Main.java:106)
Caused by: java.lang.InterruptedException: Too many errors
	at com.android.dx.command.dexer.Main.processAllFiles(Main.java:681)
	... 4 more

 اینم دوتا کتابخونه ها

لینک این دو با هم

تمامی کتابخونه هارو کامل پیوست کنید ، هرچی که استفاده می کنید.(دقیق تر مشکل پیدا بشه)

  • پسندیدن 1

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
koke_sa    40

کاربر عادی

در 37 دقیقه قبل، M-CAP7AIN گفته است :

تمامی کتابخونه هارو کامل پیوست کنید ، هرچی که استفاده می کنید.(دقیق تر مشکل پیدا بشه)

کلا هیچ چیزی جز این دو ندارم شما خودتون یک پروزه نیوکنید این دو کتابخونرو تیک بزنید . کتابخونه ah navigation draver که همون دو فایل که فرستادم دوباره میفرستم فقط کتابخونه پوشه علاوه بر اون دوتا چیز چند چیز دیگه از گوگل هم داره الان پیوست میکنم . ممنون

لینک کتابخونه ها

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
M-CAP7AIN    507

پاسخگو و راهنما

پوشه از روش استانداردی برای b4a استفاده نکرده .

برای کتابخونه هایی که همراه پوشه استفاده میشه باید به این صورت تغییر کنه

<dependsOn>***support-v4***</dependsOn>

به

<dependsOn>support-v4</dependsOn>

تغییر کنه.

 

pushe1.4.1-additional-libs.rar

این دوتا رو جایگزین و تست کنید.(ولی بازم با برخی از کتابخونه ها تداخل پیدا میکنه )

 

  • پسندیدن 1

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

مهمان
پاسخ به این سوال ...

×   شما در حال چسباندن محتوایی با قالب بندی هستید.   حذف قالب بندی

  تنها استفاده از 75 اموجی مجاز می باشد.

×   لینک شما به صورت اتوماتیک جای گذاری شد.   نمایش به عنوان یک لینک به جای

×   محتوای قبلی شما بازگردانی شد.   پاک کردن محتوای ویرایشگر

×   شما مستقیما نمی توانید تصویر خود را قرار دهید. یا آن را اینجا بارگذاری کنید یا از یک URL قرار دهید.


×
×
  • جدید...