رفتن به مطلب
  • 0

خطا اپ کامپت موقع کامپایل


Mr.Kafiri

سوال

سلام به دوستان 

موقع ران گرفتن از اپ به خطای زیر برخوردم.

B4A Version: 9.80
Java Version: 8
Parsing code.    (0.48s)
Building folders structure.    (0.41s)
Compiling code.    (4.47s)
Compiling layouts code.    (2.59s)
Organizing libraries.    (0.00s)
	(AndroidX SDK)
Generating R file.    (19.16s)
Compiling generated Java code.    (14.66s)
Convert byte code - optimized dex.    Error
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lde/amberhome/objects/appcompat/ACActionBar;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lde/amberhome/objects/appcompat/ACActionMenuWrapper;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lde/amberhome/objects/appcompat/ACActionMenuWrapper$1;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lde/amberhome/objects/appcompat/ACActionModeWrapper;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lde/amberhome/objects/appcompat/ACActionModeWrapper$1;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lde/amberhome/objects/appcompat/ACButtonWrapper;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lde/amberhome/objects/appcompat/ACCheckBoxWrapper;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lde/amberhome/objects/appcompat/ACEditTextWrapper;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lde/amberhome/objects/appcompat/ACFlatButtonWrapper;
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.RuntimeException: Translation has been interrupted
	at com.android.dx.command.dexer.Main.processAllFiles(Main.java:692)
	at com.android.dx.command.dexer.Main.runMonoDex(Main.java:315)
	at com.android.dx.command.dexer.Main.runDx(Main.java:293)
	at com.android.dx.command.dexer.Main.main(Main.java:249)
	at com.android.dx.command.Main.main(Main.java:94)
Caused by: java.lang.InterruptedException: Too many errors
	at com.android.dx.command.dexer.Main.processAllFiles(Main.java:684)
	... 4 more

اگر مشکل اینه که من این فایل ها رو در sdk ندارم لطفا یکی این فایل ها رو برام آپلود کنه هر چی sdk رو از طریق b4a آپدیت کردم بازم نشد

لینک ارسال
به اشتراک گذاری در سایت های دیگر

7 پاسخ به این سوال تاکنون داده شده است

ارسال های توصیه شده

یک اسکرینشات از کتابخونه هات بده

این تداخل کتابخونه ای هست

ببین کدوم با کدوم تداخل پیدا کرده

لینک ارسال
به اشتراک گذاری در سایت های دیگر

پرس و جو کردم گویا بخاطر اندروید x و این چیزهاست

شما به جای appcompat  از لینک زیر از کتابخونه jk_appcompat استفاده کنید هم سازگاره با اندروید x هم اینکه فک کنم مشکلتو برطرف کنه

 

کتابخونه رایگانه

 

JK_APPCOMPAT 3.3

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 5 ساعت قبل، mehrzad238 گفته است :

پرس و جو کردم گویا بخاطر اندروید x و این چیزهاست

شما به جای appcompat  از لینک زیر از کتابخونه jk_appcompat استفاده کنید هم سازگاره با اندروید x هم اینکه فک کنم مشکلتو برطرف کنه

 

کتابخونه رایگانه

 

JK_APPCOMPAT 3.3

ببخشید خیلی پررویی میکنم

نتونستم وارد سایت بشم لطفا اگه میشه کتابخانه رو همینجا پیوست کنید. :)

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 4 ساعت قبل، MrPhone گفته است :

ببخشید خیلی پررویی میکنم

نتونستم وارد سایت بشم لطفا اگه میشه کتابخانه رو همینجا پیوست کنید. :)

 

در حال جا به جایی هاست هست صاحبشون

 

http://s6.picofile.com/file/8387896818/jk_appcompat.zip.html

 

به محض درست شدن وبسایتون برید و ورژن جدیدشو بگیرید

امیدوارم مشکلتون حل شه

اگر نشد باز هم پیام بدید تا با یاری دوستان حلش کنیم

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

jdk  رو هم آپدیت کن ورژن 11 نصب کن

الان دیگه تو سایت بیسیک هم گفته 11 استفاده کن بهتره

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...