رفتن به مطلب
  • 0

Thread


Mralihjz

سوال

سلام من یک متغیر تعریف کردم از نوع Thread و intialise کردم اما تو قسمت log پیام میده که این متغیر رو intialise نکردی و هنگام کامپایل کردن این ارور رو میده:

B4A Version: 9.80
Java Version: 8
Parsing code.    (0.00s)
Building folders structure.    (0.01s)
Compiling code.    (0.02s)
Compiling layouts code.    (0.00s)
Organizing libraries.    (0.00s)
    (Android Support Library)
Generating R file.    (0.00s)
Compiling generated Java code.    Error
javac 1.8.0_131
src\Thread\er\main.java:341: error: cannot find symbol
public Thread.er.starter _starter = null;
             ^
  symbol:   class er
  location: class Thread
Note: src\Thread\er\starter.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
1 error


لطفا راهنمایی کنید خواهش میکنم فوری

لینک ارسال
به اشتراک گذاری در سایت های دیگر

7 پاسخ به این سوال تاکنون داده شده است

ارسال های توصیه شده

سلام

کدی که نوشتید رو قرار بدید

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 2 ساعت قبل، مجید آرتا گفته است :

سلام

کدی که نوشتید رو قرار بدید

 

dim x as thread

x.Initialise("thrd")

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 2 ساعت قبل، Mralihjz گفته است :

dim x as thread

x.Initialise("thrd")

احتمالا مشکل از نسخه api هست.از تنظیمات  روی 29 بزارید

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 5 دقیقه قبل، محمدرضا شاهپیری گفته است :

احتمالا مشکل از نسخه api هست.از تنظیمات  روی 29 بزارید

خیلی ممنون منظورتون همون فایل Manifest هست دیگه ؟ قسمت android:targetSdkVersion=" درست میگم؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 8 دقیقه قبل، محمدرضا شاهپیری گفته است :

احتمالا مشکل از نسخه api هست.از تنظیمات  روی 29 بزارید

این کارو انجام دادم درست نشد

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 46 دقیقه قبل، Mralihjz گفته است :

این کارو انجام دادم درست نشد

خودتون سوال میپرسین خودتونم جواب میدین:malih:

خیر باید از تنظیمات جایی که مسیر جاوا و اندروید رو میدین نسخه اندروید رو ۲۹ انتخاب کنید

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 19 ساعت قبل، محمدرضا شاهپیری گفته است :

خودتون سوال میپرسین خودتونم جواب میدین:malih:

خیر باید از تنظیمات جایی که مسیر جاوا و اندروید رو میدین نسخه اندروید رو ۲۹ انتخاب کنید

نسخه اندروید 29 رو ندارم

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...