رفتن به مطلب
  • 0

مشکل با تم Holo


qasem

سوال

سلام دوستان من هر یک از تم های holo را استفاده میکنم این ارور را میده!!!

 

1111111111111111111111.png

 

خب ممکنه بگید از یه تم دیگه استفاده کن ، من هم همین کار را انجام دادم ولی یه مشکل دیگه ای پیش آمد ، من یه برنامه صوتی زدم وقتی از تمی غیر از holo استفاده میکنم تو برنامه وقتی میخوام صدای برنامه را با کلیدهای خود گوشی کم یا زیاد کنم هیچ عکس العملی انجام نمیگره ؟ لطفا راهنمایی کنید دوستان.

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

17 پاسخ به این سوال تاکنون داده شده است

ارسال های توصیه شده

برای کار باتم هلو باید از api بالای 14 استفاده کنی با api های بالا 14 کامپایل کن اگر اسم پوشه برنامت فارسی هست ، تغییر بده انگلیسی بگذار تا داخل آدرس دهی مانیفست مشکلی نداشته باشی اگر مشکلت حل نشده یه api جدید دانلود کن و با اون هم امتحان کن ببین مشکلت حل نمیشه

لینک ارسال
به اشتراک گذاری در سایت های دیگر

متشکرم حل شد نسخه api را بالا بردم درست شد یعنی تم های holo را هم دیگه ارور نمیده ولی باز تو این تم ها کلید بالا و پایین کردن صدا عمل نمیکنه!!!!

لینک ارسال
به اشتراک گذاری در سایت های دیگر

دوستان عزیز خسته نباشید  من تا حالا تمام سیستم عامل ها رو امتحان کردم حتی بیسیک 5.2 رو الان کار میکنم ولی همچنان مشکل holo  پابرجاس   api   من 22 هست بنظرتون مشکل از کجاست

لینک ارسال
به اشتراک گذاری در سایت های دیگر

حالا ایراد سیستم من از کجاس که اینو اجرا نمیکنه 

دقیقاً مشکل شما چیه واضح توضیج بدید

لینک ارسال
به اشتراک گذاری در سایت های دیگر

اساتـــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــید منتظرم هــــــــــــــــــــــــــــا  ؟   من دیگه هر برنامه ای رو که شروع میکنم اینو حذف میکنم 

 

 

 اصن میشه بگید واقعن این holo نباشه روی اندروید 5 اجرا میشه یا نه اگه نه چیکار کنم ؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

اساتـــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــید منتظرم هــــــــــــــــــــــــــــا  ؟   من دیگه هر برنامه ای رو که شروع میکنم اینو حذف میکنم 

 

 

 اصن میشه بگید واقعن این holo نباشه روی اندروید 5 اجرا میشه یا نه اگه نه چیکار کنم ؟

به هیچ عنوان تم هلو پاک نکنید آندورید 5 که به شدت بهش احتیاج داره آندورید 4 به بالا هم بدون تم هلو اصلا معنا نداره طرحی هلو یه طرحی رسمی هست که گوگل برای آندورید 4 به بالا طراحی کرده و به هیچ عنوان نباید از داخل برنامه برش داری جاهای دیگه هم گفتم متاسفانه اطلاعات کافی ندارن تم هلو را پاک می کنن http://www.b4x.com/android/forum/threads/make-your-app-compatible-with-android-5-0-devices.45967/

لینک ارسال
به اشتراک گذاری در سایت های دیگر

http://s6.picofile.com/file/8206140218/11.png  امین جان این نمایش خطا

 

http://s3.picofile.com/file/8206140634/12.png                 این تعداد sdk  هست

 

http://s3.picofile.com/file/8206140342/13.png                                             اینم منیفست    

 

 ممنونم

 

اصن اون موقعی که با اکلیپس هم کار میکردم من با این مشکل داشتم!!!!!!!!!!

لینک ارسال
به اشتراک گذاری در سایت های دیگر

امین جان دستت درد نکنه مشکل حل شد و ماشالا به سحرخیزی شما  :tashvigh:  :tashvigh:

 

فقط  api  14  نسخه اندروید 4 به بالا رو ساپورت میکنه بنظرت چند درصد کاربرا نسخه 4 به پایین دارن؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

یعنی منظورم اینه که اگه برنامه ای با نسخه 4 به بالا  منتشر شد کاربرای زیادی احتمالا نتونن استفاده کنن اونم وقتی که برنامه پولی هست!

لینک ارسال
به اشتراک گذاری در سایت های دیگر

یعنی منظورم اینه که اگه برنامه ای با نسخه 4 به بالا  منتشر شد کاربرای زیادی احتمالا نتونن استفاده کنن اونم وقتی که برنامه پولی هست!

 

سلام وقتی یک api را برای کامپایل انتخاب می کنیم این بدین معنی هست که برنامه ما مطابق ویژگی های همون api کامپایل بشه حالا این تنظیمات می تونه شامل تم باشه یا شامل یکسری ویژگی های اضافی دیگر حالا مثلا ما یه برنامه را با api 14 کامپایل میکنیم بدین معنی هست که ما برنامه خود را مطابق آندورید 4 کامپایل کردیم یعنی اگر یه ویژگی جدید به آندورید 5 اضافه شده و ما از اون امکان داخل برنامه استفاده کردیم چون با api 14 کامپایل کردیم اون امکان داخل برنامه ی ما وجود نداره. حالا در رابطه با اینکه اگر رو گوشی هایی نصب بشه که آندورید پایین تری دارن چه مشکلی پیش میاد. در واقع مشکل خاصی پیش نمیاد مگر اینکه از یک ویژگی خاص در برنامه استفاده کردیم و اون ویژگی زیر آندورید 4 ساپپورت نمیشه که خیلی به ندرت چنین چیزی پیش میاد در بیسیک هر ویژگی ای که در آندورید های پایین جواب نمیده در توضیحات اون ویژگی ذکر شده مثلا گفته شده +19 یعنی از api 19 به بالا این ویژگی ساپورت میشه .

به نظر من برای کامپایل فعلا از api 19 استفاده کنید. اگر هم می خواستید متریال کار کنید مجبورید که از api مختص آندورید 5 به بالا استفاده کنید. 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بنظرت چند درصد کاربرا نسخه 4 به پایین دارن؟

 

حداکثر حداکثر حداکثر حداکثر 5 تا 10%

الان دیگه گوشی هایی که با قیمت 250-300 تومن هم میخرن حداقل اندروید 4.2 رو داره :write:

 

تاپیک به حالت حل شده و قفل گردید :gol:

لینک ارسال
به اشتراک گذاری در سایت های دیگر

من وقتی هر برنامه ای که تو بیسیک اجرا میکنم این تم هلو را باید حذف کنم اگه حذف نشه  همون خطای معروف رو میده   دارم از بیسیک 5.2 استفاده میکنم

لینک ارسال
به اشتراک گذاری در سایت های دیگر

من وقتی هر برنامه ای که تو بیسیک اجرا میکنم این تم هلو را باید حذف کنم اگه حذف نشه  همون خطای معروف رو میده   دارم از بیسیک 5.2 استفاده میکنم

 سلام دوست من بیسیک نسخه ی 5.2 هنوز نیامده آخرین نسخه 5.0.2 هست. اما در رابطه با اون سوالتون اگر به مشکل برمی خورید مشکل از api هست برای اینکه مطمعن بشم لطفاً یه تصویر از خطایی که میده بگذارید.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

مهمان
این موضوع برای عدم ارسال قفل گردیده است.
  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...