رفتن به مطلب
  • 0

مشکل پس از آپدیت b4a به 5.2


abbas2142

سوال

با سلام

 

من جدیدا وقتی برنامه هام رو آپدیت می کنم به یه مشکلی بر می خورم که نمی دونم چی هستش

 

یعنی وقتی برنامه رو به بازار میدم واسه بروز رسانی وقتی کاربر بخواد برنامه رو بروز رسانی کنه ارور نصب می ده و می گه برنامه نصب نشد !!!!

و کاربر باید برنامه رو حذف کنه و دوباره نصبش کنه

 

این مشکل هم زمانی شروع شده که من b4a که استفاده می کنم شده 5.2 یعنی قبلا که 4.3 بود این مشکل نبود برنامه رو مدیدام واسه بروز رسانی کاربر نصب می کرد تمام می شد می رفت الان نمی دوم چی شده ؟؟؟؟؟

 

این android.jar هم من دوتا دارم که دقیقا نمی دونم کدوم رو به 4.3 داده بودم ولی این رو می دونم که وقتی android-7 رو به برنامه (b4a) می دم ارور می ده ولی وقتی android-20 رو به برنامه می دم برنامه درست اجازی اجرا کردن برنامه هام رو می ده

 

با تشکر

لینک ارسال
به اشتراک گذاری در سایت های دیگر

8 پاسخ به این سوال تاکنون داده شده است

ارسال های توصیه شده

سلام عباس جان

فک کنم مشکل از این باشه که شما اپلیکیشن قبلیا رو با یه ورژن sdk نوشتی، جدیدارو با یه ورژن دیگه

به نظرم یه بار به این شکل تست کن

هر دورو یه api بده ببین مشکل حل میشه یا نه

بازم منتظر نظرات دوستان باش چون من تا حالا این مورد برام 

پیش نیومده :gol:

لینک ارسال
به اشتراک گذاری در سایت های دیگر

الان راهی وجود نداره که بفهمم sdk قبلی برنامه چی بوده 

 

چون همون طوری که گفته بودم من فقط دوتا sdk دارم یکی 7 و یکی 20 که وقتی 7 رو به برنامه b4a می دم ارور می ده

 

ولی با 20 نه

B4A version: 5.20
Parsing code.    (0.00s)
Compiling code.    (0.23s)
Compiling layouts code.    (0.01s)
Generating R file.    Error
AndroidManifest.xml:2: error: No resource identifier found for attribute 'installLocation' in package 'android'
AndroidManifest.xml:14: error: Error: No resource found that matches the given name (at 'theme' with value '@android:style/Theme.Holo').

وقتی

SetApplicationAttribute(android:theme, "@android:style/Theme.Holo") 

رو غیر فعال یا حذف می کنم

این ارور رو میده

B4A version: 5.20
Parsing code.    (0.00s)
Compiling code.    (0.04s)
Compiling layouts code.    (0.00s)
Generating R file.    Error
AndroidManifest.xml:2: error: No resource identifier found for attribute 'installLocation' in package 'android'

لینک ارسال
به اشتراک گذاری در سایت های دیگر

سلام.

اگه منظورت حداقل نسخه sdk نسخه های قبلی برنامته ، توی پنل بازار نشون میده. توی تب بسته ها.

Untitled_1.gif

لینک ارسال
به اشتراک گذاری در سایت های دیگر

سلام 

مثل اینکه دیشب کسی نبود ؟؟؟؟؟

 

الان آیا کسی می تونه کمک کنه

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

مهمان
این موضوع برای عدم ارسال قفل گردیده است.
  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...