رفتن به مطلب
  • 0

خطای material


FarzamPlus

سوال

سلام دوستان .

 

دلیل خطای :

 

B4A Version: 9.80
Java Version: 9
Parsing code.    (0.08s)
Building folders structure.    (0.04s)
Compiling code.    (0.12s)
Compiling layouts code.    (0.09s)
Organizing libraries.    Error
Maven artifact not found: com.google.android.material/material*** Legacy debugger is deprecated. ***
 It is recommended to switch to the default debugger (Tools - IDE Options).

 

من از منوی Tools  دستم به SDK Manager خورد ، یهو کل برنامه قاطی کرد . تا قبلش به AppCampat گیر میداد ، الان به این قسمت گیر میده .

باید چکار کنم ؟؟؟

نمیتونم برنامه رو کامپایل کنم :2::2::2:

لینک ارسال
به اشتراک گذاری در سایت های دیگر

13 پاسخ به این سوال تاکنون داده شده است

ارسال های توصیه شده

سلام

شما وارد Sdk Manager میشید، اگر موارد توصیه شده رو «صب نکردید، اونا رو دانلود کنید.(البته قبلش باید SDK تون آپدیت باشه)

اگر مشکلتون حل نشد، اینو داخل sdk manager سرچ و نصب کنید.

com.google.android.material:material

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 7 ساعت قبل، Salar82 گفته است :

سلام

شما وارد Sdk Manager میشید، اگر موارد توصیه شده رو «صب نکردید، اونا رو دانلود کنید.(البته قبلش باید SDK تون آپدیت باشه)

اگر مشکلتون حل نشد، اینو داخل sdk manager سرچ و نصب کنید.

com.google.android.material:material

 

ممنون ولی وقتی SDK Manager  رو میزنم اصلا چیزی نمیاد :

 


Downloading: https://dl.google.com/dl/android/maven2/master-index.xml
error: 
<!DOCTYPE html>
<html lang=en>
  <meta charset=utf-8>
  <meta name=viewport content="initial-scale=1, minimum-scale=1, width=device-width">
  <title>Error 404 (Not Found)!!1</title>
  <style>
    *{margin:0;padding:0}html,code{font:15px/22px arial,sans-serif}html{background:#fff;color:#222;padding:15px}body{margin:7% auto 0;max-width:390px;min-height:180px;padding:30px 0 15px}* > body{background:url(//www.google.com/images/errors/robot.png) 100% 5px no-repeat;padding-right:205px}p{margin:11px 0 22px;overflow:hidden}ins{color:#777;text-decoration:none}a img{border:0}@media screen and (max-width:772px){body{background:none;margin-top:0;max-width:none;padding-right:0}}#logo{background:url(//www.google.com/images/logos/errorpage/error_logo-150x54.png) no-repeat;margin-left:-5px}@media only screen and (min-resolution:192dpi){#logo{background:url(//www.google.com/images/logos/errorpage/error_logo-150x54-2x.png) no-repeat 0% 0%/100% 100%;-moz-border-image:url(//www.google.com/images/logos/errorpage/error_logo-150x54-2x.png) 0}}@media only screen and (-webkit-min-device-pixel-ratio:2){#logo{background:url(//www.google.com/images/logos/errorpage/error_logo-150x54-2x.png) no-repeat;-webkit-background-size:100% 100%}}#logo{display:inline-block;height:54px;width:150px}
  </style>
  <a href=//www.google.com/><span id=logo aria-label=Google></span></a>
  <p><b>404.</b> <ins>That’s an error.</ins>
  <p>  <ins>That’s all we know.</ins>

 

اینم عکس SDK Manager :

3qoh_sdk.jpg

 

تا الان مشکلی نداشتم .

همین که دستم به این SDK Manager خورد بعد از لود شدن یهو برنامه قاطی کرد .

لینک ارسال
به اشتراک گذاری در سایت های دیگر

این بخاطر اینه که Maven تحریم هست.

از سایت های تحریم شکن استفاده کنید:

بگذر

تنظیمات DNS رو انجام بدین و بعد دانلود کنید.

البته اگر Sdk شما بروز نباشه، لیست توصیه شده ها رو نمیاره.

 

 

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 21 ساعت قبل، Salar82 گفته است :

این بخاطر اینه که Maven تحریم هست.

از سایت های تحریم شکن استفاده کنید:

بگذر

تنظیمات DNS رو انجام بدین و بعد دانلود کنید.

البته اگر Sdk شما بروز نباشه، لیست توصیه شده ها رو نمیاره.

 

 

 

بابت راهنمایی شما ممنون .

ولی بعد از آپدیت شدن اون Material  حالا یه خطای دیگه اومده :

 

B4A Version: 9.80
Java Version: 11
Parsing code.    (0.05s)
Building folders structure.    (0.07s)
Compiling code.    (0.10s)
Compiling layouts code.    (0.08s)
Organizing libraries.    (0.00s)
	(AndroidX SDK)
Generating R file.    Error
c:\users\farzamplus\appdata\local\android\sdk\tools\..\extras\b4a_remote\androidx\appcompat\appcompat\1.1.0\unpacked-appcompat-1.1.0\res\values-v26\values-v26.xml:15: error: Error: No resource found that matches the given name: attr 'android:keyboardNavigationCluster'.
c:\users\farzamplus\appdata\local\android\sdk\tools\..\extras\b4a_remote\com\google\android\material\material\1.1.0\unpacked-material-1.1.0\res\values\values.xml:1027: error: Error: No resource found that matches the given name: attr 'android:dialogCornerRadius'.
c:\users\farzamplus\appdata\local\android\sdk\tools\..\extras\b4a_remote\com\google\android\material\material\1.1.0\unpacked-material-1.1.0\res\values\values.xml:1714: error: Error: No resource found that matches the given name: attr 'android:keyboardNavigationCluster'.

 

SDK Manager  منم دیگه باز نمیشه :2:

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 1 دقیقه قبل، FarzamPlus گفته است :

SDK Manager  منم دیگه باز نمیشه

شما دارین از OpenJDK 11 استفاده میکنید بخاطر همین باز نمیشه.

برش گردونید به نسخه 8.

 

از چه نسخه AppCompat استفاده می کنید؟

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 4 دقیقه قبل، Salar82 گفته است :

شما دارین از OpenJDK 11 استفاده میکنید بخاطر همین باز نمیشه.

برش گردونید به نسخه 8.

 

از چه نسخه AppCompat استفاده می کنید؟

 

قبلا 1.1.0 بود ولی الان شده 3.52

قبلا JDK9 بودم مشکلی نداشت .

الان دوباره گذاشتم همون 9 .

ولی بازم خطا میده .

لینک ارسال
به اشتراک گذاری در سایت های دیگر

از چه نسخه Android.jar استفاده می کنین؟

اپ کامپت هم الان ورژن 4 اومده

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 5 دقیقه قبل، Salar82 گفته است :

از چه نسخه Android.jar استفاده می کنین؟

اپ کامپت هم الان ورژن 4 اومده

android-25

 

آخه من تا الان مشکلی نداشتم .

لامصب نمیدونم دستم به SDK Manager  خورد همچی خطا میده الان .

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

از Android 29 یا 28 استفاده کنید.

قبلاً یه جایی خونده بودم که همیشه باید از بالاترین نسخه Android.jar استفاده کرد

امیدوارم مشکلتون حل شه.

:53::53::53::53:

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در ۱ ساعت قبل، Salar82 گفته است :

از Android 29 یا 28 استفاده کنید.

قبلاً یه جایی خونده بودم که همیشه باید از بالاترین نسخه Android.jar استفاده کرد

امیدوارم مشکلتون حل شه.

:53::53::53::53:

آقا سالار بابت راهنمایی شما ممنون .

ولی الان من دوباره موقع اجرا با JDK 9.0.4 این خطا به من میده :

 

B4A Version: 9.80
Java Version: 9
Parsing code.    (0.07s)
Building folders structure.    (0.07s)
Compiling code.    (0.13s)
Compiling layouts code.    (0.07s)
Organizing libraries.    (0.00s)
	(AndroidX SDK)
Generating R file.    (0.00s)
Compiling generated Java code.    Error
An exception has occurred in the compiler (9.0.4). Please file a bug against the Java compiler via the Java bug reporting page (http://bugreport.java.com) after checking the Bug Database (http://bugs.java.com) for duplicates. Include your program and the following diagnostic in your report. Thank you.
java.time.DateTimeException: Invalid value for MonthOfYear (valid values 1 - 12): 0
	at java.base/java.time.temporal.ValueRange.checkValidValue(ValueRange.java:311)
	at java.base/java.time.temporal.ChronoField.checkValidValue(ChronoField.java:714)
	at java.base/java.time.LocalDate.of(LocalDate.java:269)
	at java.base/java.time.LocalDateTime.of(LocalDateTime.java:336)
	at jdk.zipfs/jdk.nio.zipfs.ZipUtils.dosToJavaTime(ZipUtils.java:109)
	at jdk.zipfs/jdk.nio.zipfs.ZipFileSystem$Entry.cen(ZipFileSystem.java:1950)
	at jdk.zipfs/jdk.nio.zipfs.ZipFileSystem$Entry.readCEN(ZipFileSystem.java:1937)
	at jdk.zipfs/jdk.nio.zipfs.ZipFileSystem.getEntry(ZipFileSystem.java:1324)
	at jdk.zipfs/jdk.nio.zipfs.ZipFileSystem.getFileAttributes(ZipFileSystem.java:312)
	at jdk.zipfs/jdk.nio.zipfs.ZipPath.getAttributes(ZipPath.java:721)
	at jdk.zipfs/jdk.nio.zipfs.ZipFileSystemProvider.readAttributes(ZipFileSystemProvider.java:293)
	at java.base/java.nio.file.Files.readAttributes(Files.java:1755)
	at java.base/java.nio.file.FileTreeWalker.getAttributes(FileTreeWalker.java:219)
	at java.base/java.nio.file.FileTreeWalker.visit(FileTreeWalker.java:276)
	at java.base/java.nio.file.FileTreeWalker.next(FileTreeWalker.java:373)
	at java.base/java.nio.file.Files.walkFileTree(Files.java:2749)
	at jdk.compiler/com.sun.tools.javac.file.JavacFileManager$ArchiveContainer.<init>(JavacFileManager.java:523)
	at jdk.compiler/com.sun.tools.javac.file.JavacFileManager.getContainer(JavacFileManager.java:319)
	at jdk.compiler/com.sun.tools.javac.file.JavacFileManager.list(JavacFileManager.java:715)
	at jdk.compiler/com.sun.tools.javac.code.ClassFinder.list(ClassFinder.java:722)
	at jdk.compiler/com.sun.tools.javac.code.ClassFinder.scanUserPaths(ClassFinder.java:648)
	at jdk.compiler/com.sun.tools.javac.code.ClassFinder.fillIn(ClassFinder.java:526)
	at jdk.compiler/com.sun.tools.javac.code.ClassFinder.complete(ClassFinder.java:293)
	at jdk.compiler/com.sun.tools.javac.code.Symbol.complete(Symbol.java:633)
	at jdk.compiler/com.sun.tools.javac.code.Symbol$PackageSymbol.members(Symbol.java:1120)
	at jdk.compiler/com.sun.tools.javac.code.Symtab.listPackageModules(Symtab.java:810)
	at jdk.compiler/com.sun.tools.javac.comp.Enter.visitTopLevel(Enter.java:344)
	at jdk.compiler/com.sun.tools.javac.tree.JCTree$JCCompilationUnit.accept(JCTree.java:529)
	at jdk.compiler/com.sun.tools.javac.comp.Enter.classEnter(Enter.java:285)
	at jdk.compiler/com.sun.tools.javac.comp.Enter.classEnter(Enter.java:300)
	at jdk.compiler/com.sun.tools.javac.comp.Enter.complete(Enter.java:570)
	at jdk.compiler/com.sun.tools.javac.comp.Enter.main(Enter.java:554)
	at jdk.compiler/com.sun.tools.javac.main.JavaCompiler.enterTrees(JavaCompiler.java:1052)
	at jdk.compiler/com.sun.tools.javac.main.JavaCompiler.compile(JavaCompiler.java:923)
	at jdk.compiler/com.sun.tools.javac.main.Main.compile(Main.java:302)
	at jdk.compiler/com.sun.tools.javac.main.Main.compile(Main.java:162)
	at jdk.compiler/com.sun.tools.javac.Main.compile(Main.java:57)
	at jdk.compiler/com.sun.tools.javac.Main.main(Main.java:43)

javac 9.0.4
*** Legacy debugger is deprecated. ***
 It is recommended to switch to the default debugger (Tools - IDE Options).

 

ولی با JDK 11 خطا نمیده ، کامپایل میشه برنامه اجرا میشه ولی به یه کتابخانه گیر میده :

کتابخانه : AHNavigationDrawer

الان باید چکار کنم ؟؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 1 دقیقه قبل، FarzamPlus گفته است :

با JDK 9.0.4 این خطا به من میده

البته تو سایت مرجع گفته شده Oracle JDK 8 dh یا Open Jdk 11 رو نصب کنید.

با ورژن 11 هم مشکلی نداره.

 

میشه ارورتون رو بفرستین.

 

کتابخونه هاتون رو jetify کردین؟

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 9 دقیقه قبل، Salar82 گفته است :

میشه ارورتون رو بفرستین.

Please update to B4A-Bridge v2.30+
Logger connected to:  HUAWEI H60-L04-865520021055034
--------- beginning of main
*** Service (starter) Create ***
** Service (starter) Start **
** Activity (main) Create, isFirst = true **
** Activity (main) Resume **
** Activity (main) Pause, UserClosed = true **
** Activity (login) Create, isFirst = true **
** Activity (login) Resume **
** Activity (login) Pause, UserClosed = true **
** Activity (mainmenu) Create, isFirst = true **
mainmenu_slide (B4A line: 54)
navi.Initialize2("navi",Activity,60%x,navi.GRAVIT
java.lang.NoClassDefFoundError: Failed resolution of: Landroid/support/v4/widget/DrawerLayout$LayoutParams;
	at de.amberhome.navdrawer.NavigationDrawer.Initialize2(NavigationDrawer.java:82)
	at com.sokkan.iran.mainmenu._slide(mainmenu.java:926)
	at com.sokkan.iran.mainmenu._activity_create(mainmenu.java:399)
	at java.lang.reflect.Method.invoke(Native Method)
	at anywheresoftware.b4a.BA.raiseEvent2(BA.java:196)
	at com.sokkan.iran.mainmenu.afterFirstLayout(mainmenu.java:104)
	at com.sokkan.iran.mainmenu.access$000(mainmenu.java:17)
	at com.sokkan.iran.mainmenu$WaitForLayout.run(mainmenu.java:82)
	at android.os.Handler.handleCallback(Handler.java:743)
	at android.os.Handler.dispatchMessage(Handler.java:95)
	at android.os.Looper.loop(Looper.java:150)
	at android.app.ActivityThread.main(ActivityThread.java:5546)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:792)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:682)
Caused by: java.lang.ClassNotFoundException: Didn't find class "android.support.v4.widget.DrawerLayout$LayoutParams" on path: DexPathList[[zip file "/mnt/asec/com.sokkan.iran-1/base.apk"],nativeLibraryDirectories=[/mnt/asec/com.sokkan.iran-1/lib/arm, /vendor/lib, /system/lib]]
	at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:56)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:511)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:469)
	... 15 more
	Suppressed: java.lang.ClassNotFoundException: android.support.v4.widget.DrawerLayout$LayoutParams
		at java.lang.Class.classForName(Native Method)
		at java.lang.BootClassLoader.findClass(ClassLoader.java:781)
		at java.lang.BootClassLoader.loadClass(ClassLoader.java:841)
		at java.lang.ClassLoader.loadClass(ClassLoader.java:504)
		... 16 more
	Caused by: java.lang.NoClassDefFoundError: Class not found using the boot class loader; no stack trace available

 

در 10 دقیقه قبل، Salar82 گفته است :

کتابخونه هاتون رو jetify کردین؟

این قسمت متوجه نشدم :(

لینک ارسال
به اشتراک گذاری در سایت های دیگر

این  راه مهاجرت به Androidx هست. :)

 

اپ کامپت 4 رو از اینجا دانلود کنید.

کتابخونه هاتون رو داخل internalLibrary نریزید. وگرنه هیچ کدوم Jetify نمیشه

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...